ネットワークエンジニアの休息

1,000人の会社でNo.1になる方法。きっと何かを変えるヒントがあると思います!!

【Network】 ~CiscoルータでStatic Route設定しよう!~

ポチッと応援をお願いします(*´▽`*)

にほんブログ村 哲学・思想ブログ 人生・成功哲学へ

今回のテーマは、【Network】 ~CiscoルータでStatic Route設定しよう!~です。

 

今回使用する構成はこんな感じですので一緒にやっていきましょうね!

 

f:id:kazu-network:20180123222127j:plain

 

 

◎ 設定内容

【RT1】
interface FastEthernet0
 ip address 192.168.2.1 255.255.255.0
 no shutdown

 

interface FastEthernet2
 switchport access vlan 10

 

interface Vlan10
 ip address 192.168.1.254 255.255.255.0

 

ip route 10.1.1.0 255.255.255.0 192.168.2.254

 

 ここで注意しておきたい点が2つあります。1つ目が、FastEthernet0とFastEthernet2の違いです。Fa0はルーテッドポートで、デフォルトでシャットダウンされています。そのため、使用する場合は、必ず『no shutdown』を入力しないと接続されないので注意しておいてください。

 

 2つ目が、スタティックルートの設定です。少し分解して確認していきましょう!

 

ip route 10.1.1.0 255.255.255.0 192.168.2.254

 ・ip route ・・・ Statcルートを定義

 ・10.1.1.0 ・・・ 指定する宛先セグメント

 ・255.255.255.0 ・・・ サブネットマスクを指定

 ・192.168.2.254 ・・・ NextHopアドレス

 つまり、『10.1.1.0/24向けのパケットは192.168.2.254のアドレスを持っている機器に転送しなさい』と静的に設定しています。

 

【RT2】
interface Loopback0
 ip address 10.1.1.1 255.255.255.0

 

interface FastEthernet0/0
 ip address 192.168.2.254 255.255.255.0
 no shutdown

 

ip route 192.168.1.0 255.255.255.0 192.168.2.1

 

 ここで設定してるLoopback0とは論理的に作成されたインターフェイスのことです。

 

【RT1】

f:id:kazu-network:20180123230637j:plain

 

【RT2】

f:id:kazu-network:20180123230652j:plain

 

◎ 設定内容の確認

 今回使用するコマンドは以下になります。

 

・show running-config

・show ip interface brief

・show interfaces status

・show interfaces

・show vlan-switch(show vlan)

・show ip route

ping

 

 こんな感じに見えるはずですので、確認をしていきましょう!

 

 ・show running-config

RT1#show running-config
Building configuration...

Current configuration : 1425 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT1
!
boot-start-marker
boot config flash:startup-config
warm-reboot
boot-end-marker

!
interface FastEthernet0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!

!
interface FastEthernet2
 switchport access vlan 10

!


interface Vlan10
 ip address 192.168.1.254 255.255.255.0
!
ip route 10.1.1.0 255.255.255.0 192.168.2.254

 

 

 

RT2#show running-config
Building configuration...

Current configuration : 1105 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT2
!
boot-start-marker
boot-end-marker

interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.2.254 255.255.255.0
 duplex auto
 speed auto
!

 ・

!
ip route 192.168.1.0 255.255.255.0 192.168.2.1
!

 

 

 

・show ip interface brief

 このコマンドは、インターフェイスの設定を確認するコマンドです。今回で言いますと、RT1では、接続した『FastEthernet2』と『Vlan10』、それから『FastEthernet0』がup / upになっていることを確認してください。

 

f:id:kazu-network:20180123232830j:plain

 

 

RT2では、接続した『FastEthernet0/0』と『Loopback0』がup / upになっていることを確認してください。

f:id:kazu-network:20180123232846j:plain

 

  

・show interfaces status

 インターフェイスのDuplexとSpeedの設定を確認してください。今回は、インターフェイス設定をauto/autoで設定したため、『a-full』と『a-100』となっていればOKです。

 

 ただし、このコマンドで確認出来るのでは、スイッチポートのみとなりますので、ルーテッドポートは確認できませんのご注意ください。

 

 代わりに『show interfaces』というコメントがありますので、こちらも併せて確認してもらえればと思います。

 

f:id:kazu-network:20180123233300j:plain

 

・show interfaces

 このコマンドを使用することですべてのインターフェイスのDuplex / Speedの両方を確認することができます。使用するインターフェイスのステータスを確認してくださいね!

f:id:kazu-network:20180125233205j:plain

 

 

・show ip route

 このコマンドでルーティングテーブルを確認することができます。RT1では以下のようなログになっているはずです。

f:id:kazu-network:20180123234016j:plain

今回、注目してもらいたいのが、以下の部分です。

 

     10.0.0.0/24 is subnetted, 1 subnets

  ⇒10.0.0.0/24のサブネットを1つ持っている
S       10.1.1.0 [1/0] via 192.168.2.254

  ⇒10.1.1.0/24のネクストホップを192.168.2.254を指定
C    192.168.1.0/24 is directly connected, Vlan10

  ⇒192.168.1.0/24がVlan10で所有
C    192.168.2.0/24 is directly connected, FastEthernet0

  ⇒192.168.2.0/24がFastEthernet0で所有

 

 ここの『C』はコネクトを意味しており、所有しているセグメントであれば、この表示となります。『S』はスタティックルートであることが意味されております。

 

 

 RT2では、以下のようなログになっているはずですので、確認しておきましょう! 

f:id:kazu-network:20180123234132j:plain

 

 

ping

 このコマンドで疎通確認が取れます。このコマンドは、WindowsパソコンでもCiscoでも同じになりますが、オプションの使い方が違います。今回はCisco機器だけオプションコマンドを使いますので、少しだけ紹介しておきます。

 

【パソコン】

 パソコンからRT2のLoopback0のアドレスに向けて実行してみて下さい。以下のようになっていれば問題ありません。

f:id:kazu-network:20180126000830j:plain

 

【RT2】

 ルータからの疎通確認はLoopback0からパソコンに向けて疎通確認をしたいので、明示的に指定してあげないと、宛先に一番近いアドレスをソースにして実行してしまいます。今回で言うと、Fa0/0がソースとなってしまうことになります。

 

 それを変更するオプションが『source interface num』です。このコマンドにより指定してPingを飛ばすことができます。

 

 以下のように『!』が5つ並んでいればOKです。確認してみてくださいね。

 

f:id:kazu-network:20180126001804j:plain

 

 

◎ まとめ

 今回は、Static Routeの設定を書いてみましたが、これは静的ルーティングと言って書かれた通りにしかルートは学習できません。そのため、故障時などに自動的に切り替えるなどの設定を考慮するとかなり細かく手動で書く必要があり大変なものになります。

 

 それを自動的に学習してくれる仕組みとして動的ルーティングというものがあります。RIPやOSPFなどからCisco独自プロトコルとしてEIGRPなどがありますが、まだまだ先の話として知っておいてください。

 

 

 

【こんな記事も書いています】 

www.kazunetworkpm.xyz

www.kazunetworkpm.xyz

www.kazunetworkpm.xyz

 

 

 

※ いつもコメントブックマークありがとうございます。励みになります。

※ 面白かったらコメントブックマークを付けてもらえると嬉しいです。

 また、読者も募集していますので、ぜひともよろしくお願いします。